Rabu, 30 September 2026
08:24 WIB
TERKINI
Nasional Saksi Ungkap Penolakan Uang 1 Juta Dolar AS untuk Pansus Haji oleh Dua Tokoh Megapolitan Demo Buruh di DPR Lumpuhkan Gatot Subroto: Simak Jalur Alternatifnya Megapolitan Komunikasi Terputus Jadi Akar Tabrakan KA Argo Bromo Anggrek di Bekasi Regional KPU Batam Musnahkan Ribuan Surat Suara Rusak, Jaga Integritas Pemilu Regional Gagal Menulis Ulang: Konten Berita Tidak Memadai Way Kanan Kepala Toko Alfamart Way Kanan Diduga Gelapkan Rp141 Juta, Dua Pelaku Ditangkap Hiburan Lisa BLACKPINK Ukir Sejarah: Solois Asia Pertama Sabet Best Pop MTV VMAs 2026 Ekonomi Dan Bisnis Harga Emas Antam Turun Drastis Rp17 Ribu, Cek Daftar Lengkap 29 September 2026 Hiburan TXT Gegerkan Penggemar dengan Mini Album 'PERFECT STORM' dan Tur Dunia Termasuk Jakarta Berita Fenomena Unik 'Hujan Salju' di Lapangan Sempur Bogor, Warga Sambut Riang Nasional Saksi Ungkap Penolakan Uang 1 Juta Dolar AS untuk Pansus Haji oleh Dua Tokoh Megapolitan Demo Buruh di DPR Lumpuhkan Gatot Subroto: Simak Jalur Alternatifnya Megapolitan Komunikasi Terputus Jadi Akar Tabrakan KA Argo Bromo Anggrek di Bekasi Regional KPU Batam Musnahkan Ribuan Surat Suara Rusak, Jaga Integritas Pemilu Regional Gagal Menulis Ulang: Konten Berita Tidak Memadai Way Kanan Kepala Toko Alfamart Way Kanan Diduga Gelapkan Rp141 Juta, Dua Pelaku Ditangkap Hiburan Lisa BLACKPINK Ukir Sejarah: Solois Asia Pertama Sabet Best Pop MTV VMAs 2026 Ekonomi Dan Bisnis Harga Emas Antam Turun Drastis Rp17 Ribu, Cek Daftar Lengkap 29 September 2026 Hiburan TXT Gegerkan Penggemar dengan Mini Album 'PERFECT STORM' dan Tur Dunia Termasuk Jakarta Berita Fenomena Unik 'Hujan Salju' di Lapangan Sempur Bogor, Warga Sambut Riang
Simple Mail Transfer Protocol

Simple Mail Transfer Protocol

Bagikan:
250px-SMTP-transfer-model.svg.png?utm_source=id.wikipedia.org&utm_campaign=parser&utm_content=thumbnail
Model SMTP

Simple Mail Transfer Protocol (SMTP) adalah standar internet untuk transmisi surat elektronik. Pertama kali didefinisikan oleh RFC 821 pada tahun 1982, diperbarui pada 2008 dengan penambahan SMTP yang diperluas oleh RFC 5321; yang merupakan protokol yang digunakan secara luas saat ini.

Server surat dan agen transfer surat lainnya menggunakan SMTP untuk mengirim dan menerima pesan surat pada port TCP 25. Meskipun sistem berpemilik seperti Microsoft Exchange dan IBM Notes dan sistem email web seperti Outlook.com, Gmail dan Yahoo! Mail dapat menggunakan protokol non-standar mereka sendiri secara internal, semua menggunakan SMTP saat mengirim atau menerima email dari luar sistem mereka sendiri.

Aplikasi surat klien tingkat pengguna biasanya menggunakan SMTP hanya untuk mengirim pesan ke server surat untuk menyampaikan. Untuk ini, klien email secara tipikal mengirimkan email keluar mereka ke server mail pada port 587 atau 465 sesuai RFC 8314. Untuk mengambil pesan, IMAP dan POP3 adalah standar, tetapi server berpemilik juga sering lebih suka protokol mereka sendiri, seperti Exchange ActiveSync

Contoh Transaksi

S = Server
C = Klien
C: (inisialisasi hubungan)
S: 220 Wikipedia ESMTP server ready
C: mail from: [email protected]
S: 250 mail ok
C: rcpt to: [email protected]
S: 250 rcpt ok
C: data
S: 354 end data with CRLF.CRLF
C: -- email data --
C: CRLF.CRLF
S: 250 data ok
C: QUIT
S: 221 bye

Protokol Terkait

  • POP3 protokol untuk mengambil surat elektronik dari server.
  • IMAP sejenis dengan POP3 tetapi memiliki fitur yang lebih lengkap.

Pranala luar

  • RFC 821 SIMPLE MAIL TRANSFER PROTOCOL
  • RFC 821 STANDARD FOR THE FORMAT OF ARPA INTERNET TEXT MESSAGES


Ikon rintisan

Artikel bertopik komputer ini adalah sebuah rintisan. Anda dapat membantu Wikipedia dengan mengembangkannya.

Konten disalin dari Wikipedia Bahasa Indonesia (lisensi CC BY-SA) Lihat versi asli di Wikipedia

Rekomendasi Pilihan