Senin, 09 November 2026
19:26 WIB
TERKINI
Bandar Lampung Agenda Strategis Pemprov Lampung 6 November 2026: Revitalisasi Stadion Jadi Prioritas Bandar Lampung Harga Beras di Pasar Pasir Gintung Bandar Lampung Merangkak Naik, Stok Aman Bandar Lampung Disdag Bandar Lampung Jamin Pasokan Beras Aman hingga Akhir 2026 Insight Komitmen Pembangunan Negeri, PTBA Sabet Penghargaan Kepatuhan PNBP ESDM 2026 Pemprov Lampung Gubernur Mirza Canangkan Mulang Maya Jadi Magnet Wisata Budaya Unggulan Lampung Tuba Barat Mewujudkan Haji: Pemkab Tubaba dan BSI Ajak Masyarakat Menabung Sejak Dini Lampung Timur Bupati Ela Dekatkan Diri dengan Siswa, Pastikan Kualitas Pendidikan dan Gizi di Lampung Timur Tuba Barat Kemitraan Strategis Pemkab Tubaba dan Kejari: Wujudkan Tata Kelola Pemerintahan Akuntabel Bandar Lampung Mantan Ketua DPRD Lampung Bersaksi dalam Sidang Arinal Djunaidi Bandar Lampung Senator Bustami Zainudin dan Staf DPD Lampung Ikuti Program Cek Kesehatan Gratis Bandar Lampung Agenda Strategis Pemprov Lampung 6 November 2026: Revitalisasi Stadion Jadi Prioritas Bandar Lampung Harga Beras di Pasar Pasir Gintung Bandar Lampung Merangkak Naik, Stok Aman Bandar Lampung Disdag Bandar Lampung Jamin Pasokan Beras Aman hingga Akhir 2026 Insight Komitmen Pembangunan Negeri, PTBA Sabet Penghargaan Kepatuhan PNBP ESDM 2026 Pemprov Lampung Gubernur Mirza Canangkan Mulang Maya Jadi Magnet Wisata Budaya Unggulan Lampung Tuba Barat Mewujudkan Haji: Pemkab Tubaba dan BSI Ajak Masyarakat Menabung Sejak Dini Lampung Timur Bupati Ela Dekatkan Diri dengan Siswa, Pastikan Kualitas Pendidikan dan Gizi di Lampung Timur Tuba Barat Kemitraan Strategis Pemkab Tubaba dan Kejari: Wujudkan Tata Kelola Pemerintahan Akuntabel Bandar Lampung Mantan Ketua DPRD Lampung Bersaksi dalam Sidang Arinal Djunaidi Bandar Lampung Senator Bustami Zainudin dan Staf DPD Lampung Ikuti Program Cek Kesehatan Gratis
HTTP 302

HTTP 302

Bagikan:
HTTP
250px-HTTP_logo.svg.png?utm_source=id.wikipedia.org&utm_campaign=parser&utm_content=thumbnail
Metode permintaan
Kotak kepala
Kode status
Metode kontrol akses keamanan

Kode status tanggapan HTTP 302 Found adalah cara umum melakukan pengalihan URL. Spesifikasi HTTP/1.0 (RFC 1945) awalnya mendefinisikan kode ini, dan memberinya frasa deskripsi "Moved Temporarily" daripada "Found".

Respons HTTP dengan kode status ini juga akan memberikan URL di kolom header, Lokasi. Ini adalah undangan ke agen pengguna (mis. Peramban web) untuk membuat permintaan kedua, jika tidak identik, permintaan ke URL baru yang ditentukan di bidang lokasi. Hasil akhirnya adalah pengalihan ke URL baru.

Banyak peramban web menerapkan kode ini dengan cara yang melanggar standar ini, mengubah jenis permintaan dari permintaan baru menjadi GET, terlepas dari jenis yang digunakan dalam permintaan awal (mis. POST).[1] Untuk alasan ini, HTTP/1.1 (RFC 2616) menambahkan kode status baru 303 dan 307 untuk membedakan antara dua perilaku, dengan 303 mandat untuk mengubah jenis permintaan menjadi GET, dan 307 mempertahankan jenis permintaan seperti yang dikirim semula. Terlepas dari kejelasan yang lebih besar yang diberikan oleh disambiguasi ini, kode 302 masih digunakan dalam kerangka kerja web untuk menjaga kompatibilitas dengan peramban yang tidak menerapkan spesifikasi HTTP/1.1.[2]

Sebagai konsekuensi, RFC 7231 (pembaruan dari RFC 2616) mengubah definisi untuk memungkinkan agen pengguna menulis ulang POST menjadi GET.[3]

Contoh

Permintaan klien:

GET /index.html HTTP/1.1
Host: www.example.com

Respon peladen:

HTTP/1.1 302 Found
Location: http://www.iana.org/domains/example/

Lihat pula

Referensi

  1. ↑ Lawrence, Eric. "HTTP Methods and Redirect Status Codes". EricLaw's IEInternals blog. Diarsipkan dari versi aslinya tanggal 2013-06-21. Diakses tanggal 2011-08-20.
  2. ↑ "Request and response objects | Django documentation | Django". Docs.djangoproject.com. Diarsipkan dari versi aslinya tanggal 2014-07-10. Diakses tanggal 2014-06-23.
  3. ↑ "Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content". Tools.ietf.org. Diarsipkan dari versi aslinya tanggal 2017-05-25. Diakses tanggal 2019-01-05.

Pranala luar

Ikon rintisan

Artikel bertopik situs web ini adalah sebuah rintisan. Anda dapat membantu Wikipedia dengan mengembangkannya.

Konten disalin dari Wikipedia Bahasa Indonesia (lisensi CC BY-SA) Lihat versi asli di Wikipedia

Rekomendasi Pilihan